JSN Mico - шаблон joomla Авто
შესვლა რეგისტრაცია

შეხვიდეთ თქვენს ანგარიშზე

მომხმარებლის სახელი *
პაროლი *
დამიმახსოვრე

შექმენი ანგარიში

ველი რომელიც აღნიშნულია ვარსკვლავი (*) აუცილებელია.
სახელი *
მომხმარებლის სახელი *
პაროლი *
დაადასტურეთ პაროლი *
ელ-ფოსტა *
დაადასტურეთ ელ-ფოსტა *
Captcha *
  • dgdfgdg-laoderi.png
  • dosddos.png
  • dosddosxx.png
  • ubiquiti.png

სტატიის ამ ნაწილში ჩვენ ვნახავთ თუ რატომ გვჭირდება Netmap. შევხედოთ რეალურ მაგალითში.

მაშასე, Netmap ან 1:1 NAT საშუალებას იძლევა გარდაქმნას ერთი ქსელის მისამართი სხვა ქსელის მისამართზე 1:1.

ანუ თქვენ შეგიძლიათ დააკონვერტიროთ ქსელი 10.168.0.0/24   192.168.0.0/24-ში

ამდენად, თქვენ გაქვთ თითოეული მისამართის ერთი ქსელი, სხვა ქსელის მისამართის შესაბამისი იქნება. სხვა სიტყვებით რომ ვთქვათ, შესრულებული იქნება პირობები:

 10.168.0.1 = 192.168.0.1 ... 10.168.0.254 = 192.168.0.254

ასეთი ტიპის კონფიგურაცია არის იშვიათი, მაგრამ ზოგჯერ მის გარეშე შეუძლებელია.

ამოცანის პირობა

კლიენტს აქვს ორი ოფისი ქალაქის სხვადასხვა კუთხეში. ყოველ ოფისში ლოკალურ ქსელს აქვს ლოკალური ქსელი 192.168.0.0/24. თითოეული ოფისში მისამართების ნაწილი მეორდება. მაგალითად, ფაილების სერვერს ორივე ოფისში აქვს მისამართი 192.168.0.2.

ბევრი მოწყობილობა არის დაკავშირებული პირდაპირ IP მისამართებით.

მიზანი:

გავაერთიანოთ ორივე ქსელი VPN-ის მეშვეობით ისე რომ არ შეიცვალოს შიდა მისამართები.

ქსელის საერთო სქემა:

რა გვაქვს:

  • ერთნაირი დამისამართება ორივე ქსელის არ გვაძლევს მარშრუტიზირების საშუალებას.
  • დუბლირებული მისამართები არ გვაძლევს საშუალებას გამოვიყენოთ L2 VPN (EoIP или BCP). და ეს არის სწორედ ის შემთხვევა, როდესაც არის საჭირო 1:1 NAT

ამ ამოცანის გადაწყვეტის ძირითადი იდეა მდგომარეობდა იმაში, გარდაქმნას 1 ოფისის ქსელის მისამართი ქვექსელით 192.168.1.0/24, ხოლო 2 ოფისის მისამართი ქვექსელით 192.168.2.0/24
მაშინ ოფისი 1 შეეძლო მიემართა რესურსებზე ოფისი 2 მისამართებით 192.168.2.x, ხოლო 2 ოფისს მიემართა 1 ოფისის რესურსებზე მისამართზე 192.168.1.h. ამასთან რესურსების მისამართები ოფისის სიგნით დარჩებოდა შეუცვლელი.

მუშაობის სქემა

მაშასე, შევხედოთ ამ სქემას.

სქემის მწვანე ნაწილი არის კონვერციის.

  1. პაკეტი 1 ოფისიდან, მისამართით 192.168.0.x, იგზავნება 2 ოფისში მისამართით 2 192.168.2.x
     
  2. როდესაც დამუშავდება 1 მარშრუტიზატორზე, პაკეტის გამომგზავნელის მისამართი შეიცვლება 192.168.1.x (src-nat)
     
  3. როდესაც 2 მარშრუტიზატორი მიიღებს პაკეტს, პაკეტის დანიშნულების მისამართი შეიცვლება 192.168.0.h (dst-nat)

კონვერციის სქემის ლურჟი ნაწილი არის სარკისებრი ჩვენება მწვანის.

  1. პაკეტი 2 ოფისიდან, მისამართით 192.168.0.h, იგზავნება 1 ოფისში მისამართით 192.168.1.h
  2. როდესაც დამუსავდება 2 მარშრუტიზატორზე, პაკეტის გამომგზავნელის მისამართი შეიცვლება 192.168.2.h (src-nat)
  3. როდესაც 2 მარშრუტიზატორი მიიღებს პაკეტს, პაკეტის დანიშნულების მისამართი შეიცვლება 192.168.0.h (DST-nat)

ამგვარად:

  1. ყველა ჰოსტი 1 ოფისის, თვლის რომ 2 ოფისის ლოკალურ ქსელს აქვს მისამართი ქვექსელიდან 192.168.2.0/24, და მათ საკუთარ ლოკალურ ქსელს აქვს მისამართი ქვექსელში 192.168.0.0/24
  2. ყველა ჰოსტი 2 ოფისის, თვლის რომ 1 ოფისის ლოკალურ ქსელს აქვს მისამართი ქვექსელიდან 192.168.1.0/24, და მათ საკუთარ ლოკალურ ქსელს აქვს მისამართი ქვექსელში 192.168.0.0/24

დავაკონფიგურიროთ.

1 ოფისის მარშრუტიზატორი

 

/ip firewall nat add action=netmap chain=srcnat dst-address=192.168.2.0/24 src-address=192.168.0.0/24\ to-addresses=192.168.1.0/24 add action=netmap chain=dstnat dst-address=192.168.1.0/24 src-address=192.168.2.0/24\ to-addresses=192.168.0.0/24

2 ოფისის მარშრუნიზატორს აქვს ანლოგიური კონფიგურაცია
/ip firewall nat add action=netmap chain=srcnat dst-address=192.168.1.0/24 src-address=192.168.0.0/24\ to-addresses=192.168.2.0/24 add action=netmap chain=dstnat dst-address=192.168.2.0/24 src-address=192.168.1.0/24\ to-addresses=192.168.0.0/24

საბოლოო ფორმისთვის მივცეთ მარშრუტები (თვით გამმართავი VPN სტატიის თემაში არ შედის.

1 ოფისის მარშრუტიზატორი

/ip route add distance=1 dst-address=192.168.2.0/24 gateway=10.10.10.2

2 ოფისის მარშრუტიზატორი

/ip route add distance=1 dst-address=192.168.1.0/24 gateway=10.10.10.1

სტატიის ამ ნაწილში ჩვენ გავიგეთ თუ რატომ გვჭირდება 1:1 NAT და როდის უნდა გამოვიყენოთ ეს კონფიგურაცია.

 ტექნიკური დირექტორი ილია კნიაზევი (MTCNA, MTCWE, MTCTCE)
 სტატია ნათარგმნია რუსულიდან ქართულზე, jsh-ის მიერ. infoit.ge

სხვა სტატიები:

საიტი შეიცავს მხოლოდ გადამოწმებულ მასალას MikroTik-ის მოწყობილობების დასაკონფიგურირებლად.

ჩვენ ვიყენებთ Cookies-ს, რათა დავრწმუნდეთ იმაში, რომ გაძლევთ საუკეთესო გამოცდილებას ჩვენს ვებ-გვერდზე ყოფნისას. Cookies-ს გამოყენებასთან დაკავშირებით ამომწურავი ინფორმაცია იხილეთ Cookie პოლიტიკა. ამ საიტის გამოყენებით თქვენ ავტომატურად ეთანხმებით Cookies-ის გამოყენების უფლებას.